PyPI/tensorflow CVE-2021-41226: unknown, EPSS 0.21%
TensorFlow is an open source platform for machine learning. In affected versions the implementation of `SparseBinCount` is vulnerable to a heap OOB access. This is because of missing validation betwee
Action: Upgrade tensorflow to 2.4.4 or later.
pip install tensorflow==2.4.4pip install tensorflow==2.5.2pip install tensorflow==2.6.1pip install tensorflow==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
| 2.7.0rc0 | 2.7.0 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 | 2.7.0 |
Sources
- osv: PYSEC-2021-418
- https://github.com/tensorflow/tensorflow/commit/f410212e373eb2aec4c9e60bf3702eba99a38aba
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-374m-jm66-3vj8
CVE-2021-41226 · published · modified · JSON