PyPI/tensorflow-cpu CVE-2021-29532: unknown, EPSS 0.20%
TensorFlow is an end-to-end open source platform for machine learning. An attacker can force accesses outside the bounds of heap allocated arrays by passing in invalid tensor values to `tf.raw_ops.Rag
Action: Upgrade tensorflow-cpu to 2.2.0rc0 or later.
pip install tensorflow-cpu==2.2.0rc0pip install tensorflow-cpu==2.3.0rc0pip install tensorflow-cpu==2.3.4pip install tensorflow-cpu==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.0rc0 | - |
| 2.2.0 | 2.3.0rc0 | - |
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.2.0rc0 | 2.3.0rc0 | 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-460
- https://github.com/tensorflow/tensorflow/commit/44b7f486c0143f68b56c34e2d01e146ee445134a
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j47f-4232-hvv8
CVE-2021-29532 · published · modified · JSON