PyPI/tensorflow-cpu CVE-2021-29579: unknown, EPSS 0.21%
TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.MaxPoolGrad` is vulnerable to a heap buffer overflow. The implementation(https://github.com/ten
Action: Upgrade tensorflow-cpu to 2.1.4 or later.
pip install tensorflow-cpu==2.1.4pip install tensorflow-cpu==2.2.3pip install tensorflow-cpu==2.3.3pip install tensorflow-cpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: PYSEC-2021-507
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-79fv-9865-4qcv
- https://github.com/tensorflow/tensorflow/commit/a74768f8e4efbda4def9f16ee7e13cf3922ac5f7
CVE-2021-29579 · published · modified · JSON