PyPI/tensorflow-cpu CVE-2021-29600: unknown, EPSS 0.20%
TensorFlow is an end-to-end open source platform for machine learning. The implementation of the `OneHot` TFLite operator is vulnerable to a division by zero error(https://github.com/tensorflow/tensor
Action: Upgrade tensorflow-cpu to 2.1.4 or later.
pip install tensorflow-cpu==2.1.4pip install tensorflow-cpu==2.2.3pip install tensorflow-cpu==2.3.3pip install tensorflow-cpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: PYSEC-2021-528
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j8qh-3xrq-c825
- https://github.com/tensorflow/tensorflow/commit/3ebedd7e345453d68e279cfc3e4072648e5e12e5
CVE-2021-29600 · published · modified · JSON