PyPI/tensorflow-cpu CVE-2021-41205: unknown, EPSS 0.15%
TensorFlow is an open source platform for machine learning. In affected versions the shape inference functions for the `QuantizeAndDequantizeV*` operations can trigger a read outside of bounds of heap
Action: Upgrade tensorflow-cpu to 2.4.4 or later.
pip install tensorflow-cpu==2.4.4pip install tensorflow-cpu==2.5.2pip install tensorflow-cpu==2.6.1pip install tensorflow-cpu==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
| 2.7.0rc0 | 2.7.0 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 | 2.7.0 |
Sources
- osv: PYSEC-2021-615
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-49rx-x2rw-pc6f
- https://github.com/tensorflow/tensorflow/commit/7cf73a2274732c9d82af51c2bc2cf90d13cd7e6d
CVE-2021-41205 · published · modified · JSON