tocsin

PyPI/cryptography CVE-2020-25659: unknown, EPSS 2.46%

python-cryptography 3.2 is vulnerable to Bleichenbacher timing attacks in the RSA decryption API, via timed processing of valid PKCS#1 v1.5 ciphertext.

Action: Upgrade cryptography to 3.2.1 or later.

pip install cryptography==3.2.1

Affected

introducedfixedlast affected
03.2.1-

Fixed versions

3.2.1

Sources

CVE-2020-25659 · published · modified · JSON