PyPI/tensorflow-gpu CVE-2021-29544: unknown, EPSS 0.31%
TensorFlow is an end-to-end open source platform for machine learning. An attacker can trigger a denial of service via a `CHECK`-fail in `tf.raw_ops.QuantizeAndDequantizeV4Grad`. This is because the i
Action: Upgrade tensorflow-gpu to 2.2.0rc0 or later.
pip install tensorflow-gpu==2.2.0rc0pip install tensorflow-gpu==2.3.0rc0pip install tensorflow-gpu==2.3.4pip install tensorflow-gpu==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.0rc0 | - |
| 2.2.0 | 2.3.0rc0 | - |
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.2.0rc0 | 2.3.0rc0 | 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-670
- https://github.com/tensorflow/tensorflow/commit/20431e9044cf2ad3c0323c34888b192f3289af6b
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6g85-3hm8-83f9
CVE-2021-29544 · published · modified · JSON