PyPI/tensorflow-gpu CVE-2021-29583: unknown, EPSS 0.21%
TensorFlow is an end-to-end open source platform for machine learning. The implementation of `tf.raw_ops.FusedBatchNorm` is vulnerable to a heap buffer overflow. If the tensors are empty, the same imp
Action: Upgrade tensorflow-gpu to 2.2.0rc0 or later.
pip install tensorflow-gpu==2.2.0rc0pip install tensorflow-gpu==2.3.0rc0pip install tensorflow-gpu==2.3.4pip install tensorflow-gpu==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.0rc0 | - |
| 2.2.0 | 2.3.0rc0 | - |
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.2.0rc0 | 2.3.0rc0 | 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-709
- https://github.com/tensorflow/tensorflow/commit/6972f9dfe325636b3db4e0bc517ee22a159365c0
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9xh4-23q4-v6wr
CVE-2021-29583 · published · modified · JSON