PyPI/tensorflow-gpu CVE-2021-41196: unknown, EPSS 0.24%
TensorFlow is an open source platform for machine learning. In affected versions the Keras pooling layers can trigger a segfault if the size of the pool is 0 or if a dimension is negative. This is due
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.4.4pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.6.1pip install tensorflow-gpu==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
| 2.7.0rc0 | 2.7.0 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 | 2.7.0 |
Sources
- osv: PYSEC-2021-804
- https://github.com/tensorflow/tensorflow/issues/51936
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-m539-j985-hcr8
- https://github.com/tensorflow/tensorflow/commit/12b1ff82b3f26ff8de17e58703231d5a02ef1b8b
CVE-2021-41196 · published · modified · JSON