PyPI/tensorflow-gpu CVE-2021-41212: unknown, EPSS 0.21%
TensorFlow is an open source platform for machine learning. In affected versions the shape inference code for `tf.ragged.cross` can trigger a read outside of bounds of heap allocated array. The fix wi
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.4.4pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.6.1pip install tensorflow-gpu==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
| 2.7.0rc0 | 2.7.0 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 | 2.7.0 |
Sources
- osv: PYSEC-2021-819
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-fr77-rrx3-cp7g
- https://github.com/tensorflow/tensorflow/commit/fa6b7782fbb14aa08d767bc799c531f5e1fb3bb8
CVE-2021-41212 · published · modified · JSON