PyPI/tensorflow CVE-2021-41206: unknown, EPSS 0.18%
TensorFlow is an open source platform for machine learning. In affected versions several TensorFlow operations are missing validation for the shapes of the tensor arguments involved in the call. Depen
Action: Upgrade tensorflow to 2.4.4 or later.
pip install tensorflow==2.4.4pip install tensorflow==2.5.2pip install tensorflow==2.6.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 |
Sources
- osv: PYSEC-2021-843
- https://github.com/tensorflow/tensorflow/commit/68422b215e618df5ad375bcdc6d2052e9fd3080a
- https://github.com/tensorflow/tensorflow/commit/4d74d8a00b07441cba090a02e0dd9ed385145bf4
- https://github.com/tensorflow/tensorflow/commit/579261dcd446385831fe4f7457d802a59685121d
- https://github.com/tensorflow/tensorflow/commit/e7f497570abb6b4ae5af4970620cd880e4c0c904
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-pgcq-h79j-2f69
- https://github.com/tensorflow/tensorflow/commit/da4aad5946be30e5f049920fa076e1f7ef021261
- https://github.com/tensorflow/tensorflow/commit/4dddb2fd0b01cdd196101afbba6518658a2c9e07
CVE-2021-41206 · published · modified · JSON