PyPI/awsiotsdk CVE-2021-40828: unknown, EPSS 0.41%
Connections initialized by the AWS IoT Device SDK v2 for Java (versions prior to 1.3.3), Python (versions prior to 1.5.18), C++ (versions prior to 1.12.7) and Node.js (versions prior to 1.5.1) did not
Action: Upgrade awsiotsdk to 1.5.18 or later.
pip install awsiotsdk==1.5.18Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.5.18 | - |
Fixed versions
| 1.5.18 |
Sources
- osv: PYSEC-2021-861
- https://github.com/aws/aws-iot-device-sdk-js-v2
- https://github.com/awslabs/aws-c-io/
- https://github.com/aws/aws-iot-device-sdk-python-v2
- https://github.com/aws/aws-iot-device-sdk-cpp-v2
- https://github.com/aws/aws-iot-device-sdk-java-v2
- https://github.com/advisories/GHSA-94jq-q5v2-76wj
CVE-2021-40828 · published · modified · JSON