PyPI/gerapy CVE-2021-43857: unknown, EPSS 55.61%
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
Action: Upgrade gerapy to 0.9.8 or later.
pip install gerapy==0.9.8Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.9.8 | - |
Fixed versions
| 0.9.8 |
Sources
- osv: PYSEC-2021-867
- https://github.com/Gerapy/Gerapy/security/advisories/GHSA-9w7f-m4j4-j3xw
- https://github.com/Gerapy/Gerapy/issues/219
- https://github.com/Gerapy/Gerapy/commit/49bcb19be5e0320e7e1535f34fe00f16a3cf3b28
- http://packetstormsecurity.com/files/165459/Gerapy-0.9.7-Remote-Code-Execution.html
CVE-2021-43857 · published · modified · JSON