PyPI/cvxopt CVE-2021-41500: unknown, EPSS 1.19%
Incomplete string comparison vulnerability exits in cvxopt.org cvxop <= 1.2.6 in APIs (cvxopt.cholmod.diag, cvxopt.cholmod.getfactor, cvxopt.cholmod.solve, cvxopt.cholmod.spsolve), which allows attack
Action: Upgrade cvxopt to 1.2.7 or later.
pip install cvxopt==1.2.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.2.7 | - |
Fixed versions
| 1.2.7 |
Sources
- osv: PYSEC-2021-870
- https://github.com/cvxopt/cvxopt/issues/193
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CXTPM3DGVYTYQ54OFCMXZVWVOMR7JM2D/
- https://github.com/advisories/GHSA-8rh6-h94m-vj54
CVE-2021-41500 · published · modified · JSON