PyPI/tensorflow-gpu CVE-2022-21732: unknown, EPSS 0.77%
Tensorflow is an Open Source Machine Learning Framework. The implementation of `ThreadPoolHandle` can be used to trigger a denial of service attack by allocating too much memory. This is because the `
Action: Upgrade tensorflow-gpu to 2.5.3 or later.
pip install tensorflow-gpu==2.5.3pip install tensorflow-gpu==2.6.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.3 | - |
| 2.6.0 | 2.6.3 | - |
Fixed versions
| 2.5.3 | 2.6.3 |
Sources
- osv: PYSEC-2022-111
- https://github.com/tensorflow/tensorflow/commit/e3749a6d5d1e8d11806d4a2e9cc3123d1a90b75e
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-c582-c96p-r5cq
- https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/data/experimental/threadpool_dataset_op.cc#L79-L135
CVE-2022-21732 · published · modified · JSON