PyPI/tensorflow-gpu CVE-2022-23592: unknown, EPSS 0.86%
Tensorflow is an Open Source Machine Learning Framework. TensorFlow's type inference can cause a heap out of bounds read as the bounds checking is done in a `DCHECK` (which is a no-op during productio
Action: Upgrade tensorflow-gpu to 2.8.0 or later.
pip install tensorflow-gpu==2.8.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0 | 2.8.0 | - |
Fixed versions
| 2.8.0 |
Sources
- osv: PYSEC-2022-156
- https://github.com/tensorflow/tensorflow/blob/274df9b02330b790aa8de1cee164b70f72b9b244/tensorflow/core/graph/graph.cc#L223-L229
- https://github.com/tensorflow/tensorflow/commit/c99d98cd189839dcf51aee94e7437b54b31f8abd
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq36-27g6-p492
CVE-2022-23592 · published · modified · JSON