tocsin

PyPI/libvcs CVE-2022-21187: unknown, EPSS 3.62%

The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command.

Action: Upgrade libvcs to 0.11.1 or later.

pip install libvcs==0.11.1

Affected

introducedfixedlast affected
00.11.1-

Fixed versions

0.11.1

Sources

CVE-2022-21187 · published · modified · JSON