PyPI/django CVE-2022-34265: unknown, EPSS 73.61%
An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. The Trunc() and Extract() database functions are subject to SQL injection if untrusted data is used as a kind/lookup_name valu
Action: Upgrade django to 3.2.14 or later.
pip install django==3.2.14pip install django==4.0.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.2 | 3.2.14 | - |
| 4.0 | 4.0.6 | - |
Fixed versions
| 3.2.14 | 4.0.6 |
Sources
- osv: PYSEC-2022-213
- https://www.djangoproject.com/weblog/2022/jul/04/security-releases/
- https://docs.djangoproject.com/en/4.0/releases/security/
- https://groups.google.com/forum/#!forum/django-announce
- https://github.com/advisories/GHSA-p64x-8rxx-wf6q
CVE-2022-34265 · published · modified · JSON