PyPI/pyspark CVE-2022-33891: unknown, exploited, EPSS 93.24%
The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or mo
Action: Upgrade pyspark to 3.1.3 or later.
pip install pyspark==3.1.3pip install pyspark==3.2.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.3 | - |
| 3.2.0 | 3.2.2 | - |
Fixed versions
| 3.1.3 | 3.2.2 |
Sources
- osv: PYSEC-2022-236
- kev: CVE-2022-33891
- https://lists.apache.org/thread/p847l3kopoo5bjtmxrcwk21xp6tjxqlc
- https://github.com/advisories/GHSA-4x9r-j582-cgr8
CVE-2022-33891 · published · modified · JSON