tocsin

PyPI/mako CVE-2022-40023: unknown, EPSS 2.32%

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

Action: Upgrade mako to 1.2.2 or later.

pip install mako==1.2.2

Affected

introducedfixedlast affected
01.2.2-

Fixed versions

1.2.2

Sources

CVE-2022-40023 · published · modified · JSON