tocsin

PyPI/joblib CVE-2022-21797: unknown, EPSS 2.63%

The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.

Action: Upgrade joblib to 1.2.0 or later.

pip install joblib==1.2.0

Affected

introducedfixedlast affected
01.2.0-

Fixed versions

1.2.0

Sources

CVE-2022-21797 · published · modified · JSON