PyPI/django CVE-2022-41323: unknown, EPSS 3.75%
In Django 3.2 before 3.2.16, 4.0 before 4.0.8, and 4.1 before 4.1.2, internationalized URLs were subject to a potential denial of service attack via the locale parameter, which is treated as a regular
Action: Upgrade django to 3.2.16 or later.
pip install django==3.2.16pip install django==4.0.8pip install django==4.1.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.2 | 3.2.16 | - |
| 4.0 | 4.0.8 | - |
| 4.1 | 4.1.2 | - |
Fixed versions
| 3.2.16 | 4.0.8 | 4.1.2 |
Sources
- osv: PYSEC-2022-304
- https://docs.djangoproject.com/en/4.0/releases/security/
- https://github.com/django/django/commit/5b6b257fa7ec37ff27965358800c67e2dd11c924
- https://www.djangoproject.com/weblog/2022/oct/04/security-releases/
- https://groups.google.com/forum/#!forum/django-announce
- https://github.com/advisories/GHSA-qrw5-5h28-6cmg
CVE-2022-41323 · published · modified · JSON