PyPI/python-libnmap CVE-2022-30284: unknown, EPSS 5.46%
** DISPUTED ** In the python-libnmap package through 0.7.2 for Python, remote command execution can occur (if used in a client application that does not validate arguments). NOTE: the vendor believes
Action: Upgrade python-libnmap to 0.7.3 or later.
pip install python-libnmap==0.7.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.7.3 | - |
Fixed versions
| 0.7.3 |
Sources
- osv: PYSEC-2022-42999
- https://github.com/savon-noir/python-libnmap/releases
- https://www.swascan.com/security-advisory-libnmap-2/
- https://pypi.org/project/python-libnmap/
- https://libnmap.readthedocs.io/en/latest/process.html#using-libnmap-process
- https://github.com/advisories/GHSA-qwqv-j7jr-4hp6
CVE-2022-30284 · published · modified · JSON