PyPI/selenium CVE-2022-28108: high 8.8, EPSS 22.54%
Selenium Server (Grid) before 4 allows CSRF because it permits non-JSON content types such as application/x-www-form-urlencoded, multipart/form-data, and text/plain.
Action: Upgrade selenium to 4.0.0 or later.
pip install selenium==4.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.0.0 | - |
Fixed versions
| 4.0.0 |
Sources
- osv: PYSEC-2022-43167
- https://www.gabriel.urdhr.fr/2022/02/07/selenium-standalone-server-csrf-dns-rebinding-rce/
- https://www.selenium.dev/downloads/
- https://www.openwall.com/lists/oss-security/2022/02/07/3
CVE-2022-28108 · published · modified · JSON