PyPI/poetry CVE-2022-36070: high 7.3, EPSS 0.36%
Poetry is a dependency manager for Python. To handle dependencies that come from a Git repository, Poetry executes various commands, e.g. `git config`. These commands are being executed using the exec
Action: Upgrade poetry to 1.1.9 or later.
pip install poetry==1.1.9Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.1.9 | - |
Fixed versions
| 1.1.9 |
Sources
- osv: PYSEC-2022-43179
- https://github.com/python-poetry/poetry/security/advisories/GHSA-j4j9-7hg9-97g6
- https://github.com/python-poetry/poetry/releases/tag/1.1.9
- https://github.com/python-poetry/poetry/releases/tag/1.2.0b1
- https://github.com/advisories/GHSA-j4j9-7hg9-97g6
CVE-2022-36070 · published · modified · JSON