PyPI/tensorflow-cpu CVE-2022-21729: unknown, EPSS 0.79%
Tensorflow is an Open Source Machine Learning Framework. The implementation of `UnravelIndex` is vulnerable to a division by zero caused by an integer overflow bug. The fix will be included in TensorF
Action: Upgrade tensorflow-cpu to 2.5.3 or later.
pip install tensorflow-cpu==2.5.3pip install tensorflow-cpu==2.6.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.3 | - |
| 2.6.0 | 2.6.3 | - |
Fixed versions
| 2.5.3 | 2.6.3 |
Sources
- osv: PYSEC-2022-53
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-34f9-hjfq-rr8j
- https://github.com/tensorflow/tensorflow/commit/58b34c6c8250983948b5a781b426f6aa01fd47af
- https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/unravel_index_op.cc#L36-L135
CVE-2022-21729 · published · modified · JSON