PyPI/django-cms CVE-2021-44649: unknown, EPSS 0.62%
Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allo
Action: Upgrade django-cms to 3.4.7 or later.
pip install django-cms==3.4.7pip install django-cms==3.5.4pip install django-cms==3.6.1pip install django-cms==3.7.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.4.0 | 3.4.7 | - |
| 3.5.0 | 3.5.4 | - |
| 3.6.0 | 3.6.1 | - |
| 3.7.0 | 3.7.4 | - |
Fixed versions
| 3.4.7 | 3.5.4 | 3.6.1 | 3.7.4 |
Sources
- osv: PYSEC-2022-7
- https://www.django-cms.org/en/blog/2020/07/22/django-cms-security-updates-1/
- https://sahildhar.github.io/blogpost/Django-CMS-Reflected-XSS-Vulnerability/
- https://github.com/advisories/GHSA-hx7c-qpfq-xcrp
CVE-2021-44649 · published · modified · JSON