tocsin

PyPI/django CVE-2023-36053: unknown, EPSS 2.98%

In Django 3.2 before 3.2.20, 4 before 4.1.10, and 4.2 before 4.2.3, EmailValidator and URLValidator are subject to a potential ReDoS (regular expression denial of service) attack via a very large numb

Action: Upgrade django to 3.2.20 or later.

pip install django==4.2.3
pip install django==4.1.10
pip install django==3.2.20

Affected

introducedfixedlast affected
3.23.2.20-
4.04.1.10-
4.24.2.3-

Fixed versions

4.2.34.1.103.2.20

Sources

CVE-2023-36053 · published · modified · JSON