PyPI/langchain CVE-2023-36189: unknown, EPSS 1.25%
SQL injection vulnerability in langchain v.0.0.64 allows a remote attacker to obtain sensitive information via the SQLDatabaseChain component.
Action: Upgrade langchain to 0.0.247 or later.
pip install langchain==0.0.247Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.247 | - |
Fixed versions
| 0.0.247 |
Sources
- osv: PYSEC-2023-110
- https://github.com/langchain-ai/langchain/pull/8425
- https://github.com/langchain-ai/langchain/issues/5923
- https://github.com/advisories/GHSA-7q94-qpjr-xpgm
CVE-2023-36189 · published · modified · JSON