PyPI/json2xml CVE-2022-25024: unknown, EPSS 1.31%
The json2xml package through 3.12.0 for Python allows an error in typecode decoding enabling a remote attack that can lead to an exception, causing a denial of service.
Action: Upgrade json2xml to 3.14.0 or later.
pip install json2xml==3.14.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.14.0 | - |
Fixed versions
| 3.14.0 |
Sources
- osv: PYSEC-2023-149
- https://packaging.python.org/en/latest/guides/analyzing-pypi-package-downloads/
- https://github.com/vinitkumar/json2xml/pull/107/files
- https://github.com/vinitkumar/json2xml/pull/107
- https://github.com/vinitkumar/json2xml/issues/106
- https://github.com/advisories/GHSA-8rj5-2857-877j
CVE-2022-25024 · published · modified · JSON