PyPI/avro CVE-2023-39410: high 7.5, EPSS 2.22%
When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system.
Action: Upgrade avro to 1.11.3 or later.
pip install avro==1.11.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.11.3 | - |
Fixed versions
| 1.11.3 |
Sources
- osv: PYSEC-2023-188
- https://lists.apache.org/thread/q142wj99cwdd0jo5lvdoxzoymlqyjdds
- http://www.openwall.com/lists/oss-security/2023/09/29/6
CVE-2023-39410 · published · modified · JSON