PyPI/vantage6 CVE-2023-23930: high 7.2, EPSS 1.11%
vantage6 is privacy preserving federated learning infrastructure. Versions prior to 4.0.0 use pickle, which has known security issue, as a default serialization module but that has known security issu
Action: Upgrade vantage6 to 4.0.2 or later.
pip install vantage6==4.0.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.0.2 | - |
Fixed versions
| 4.0.2 |
Sources
- osv: PYSEC-2023-196
- https://medium.com/ochrona/python-pickle-is-notoriously-insecure-d6651f1974c9
- https://github.com/vantage6/vantage6/security/advisories/GHSA-5m22-cfq9-86x6
- https://github.com/vantage6/vantage6/blob/0682c4288f43fee5bcc72dc448cdd99bd7e57f76/docs/release_notes.rst#400
- https://github.com/vantage6/vantage6/commit/e62f03bacf2247bd59eed217e2e7338c3a01a5f0
CVE-2023-23930 · published · modified · JSON