PyPI/apache-airflow CVE-2023-42780: medium 6.5, EPSS 1.44%
Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAG
Action: Upgrade apache-airflow to 2.7.2 or later.
pip install apache-airflow==2.7.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.2 | - |
Fixed versions
| 2.7.2 |
Sources
- osv: PYSEC-2023-202
- https://github.com/apache/airflow/pull/34355
- https://lists.apache.org/thread/h5tvsvov8j55wojt5sojdprs05oby34d
- https://github.com/advisories/GHSA-cgx2-rrmr-jx43
CVE-2023-42780 · published · modified · JSON