PyPI/coderedcms CVE-2021-46897: unknown, EPSS 0.89%
views.py in Wagtail CRX CodeRed Extensions (formerly CodeRed CMS or coderedcms) before 0.22.3 allows upward protected/..%2f..%2f path traversal when serving protected media.
Action: Upgrade coderedcms to 0.22.3 or later.
pip install coderedcms==0.22.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.22.3 | - |
Fixed versions
| 0.22.3 |
Sources
- osv: PYSEC-2023-210
- https://github.com/coderedcorp/coderedcms/issues/448
- https://github.com/coderedcorp/coderedcms/pull/450
- https://github.com/coderedcorp/coderedcms/compare/v0.22.2...v0.22.3
- https://github.com/advisories/GHSA-h454-rq3m-89rc
CVE-2021-46897 · published · modified · JSON