tocsin

PyPI/django CVE-2023-41164: unknown, EPSS 1.52%

In Django 3.2 before 3.2.21, 4.1 before 4.1.11, and 4.2 before 4.2.5, django.utils.encoding.uri_to_iri() is subject to a potential DoS (denial of service) attack via certain inputs with a very large n

Action: Upgrade django to 3.2.21 or later.

pip install django==3.2.21
pip install django==4.1.11
pip install django==4.2.5

Affected

introducedfixedlast affected
3.23.2.21-
4.14.1.11-
4.24.2.5-

Fixed versions

3.2.214.1.114.2.5

Sources

CVE-2023-41164 · published · modified · JSON