PyPI/searchor CVE-2023-43364: critical 9.8, EPSS 2.86%
main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.
Action: Upgrade searchor to 2.4.2 or later.
pip install searchor==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.2 | - |
Fixed versions
| 2.4.2 |
Sources
- osv: PYSEC-2023-262
- https://github.com/ArjunSharda/Searchor/pull/130
- https://github.com/nexis-nexis/Searchor-2.4.0-POC-Exploit-
- https://github.com/nikn0laty/Exploit-for-Searchor-2.4.0-Arbitrary-CMD-Injection
- https://github.com/advisories/GHSA-66m2-493m-crh2
- https://github.com/ArjunSharda/Searchor/commit/16016506f7bf92b0f21f51841d599126d6fcd15b
CVE-2023-43364 · published · modified · JSON