PyPI/apache-airflow CVE-2023-47265: medium 5.4, EPSS 1.34%
Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. Thi
Action: Upgrade apache-airflow to 2.8.0b1 or later.
pip install apache-airflow==2.8.0b1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.8.0b1 | - |
Fixed versions
| 2.8.0b1 |
Sources
- osv: PYSEC-2023-264
- https://github.com/apache/airflow/pull/35460
- https://lists.apache.org/thread/128f3zl375vb1qv93k82zhnwkpl233pr
- http://www.openwall.com/lists/oss-security/2023/12/21/2
- https://github.com/advisories/GHSA-pxch-wr7m-rwxj
CVE-2023-47265 · published · modified · JSON