PyPI/vyper CVE-2023-42443: high 8.1, EPSS 0.83%
Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine (EVM). In version 0.3.9 and prior, under certain conditions, the memory used by the builtins `raw_call`, `create_from_bluep
Action: Upgrade vyper to 0.3.10 or later.
pip install vyper==0.3.10Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3.10 | - |
Fixed versions
| 0.3.10 |
Sources
- osv: PYSEC-2023-306
- https://github.com/vyperlang/vyper/security/advisories/GHSA-c647-pxm2-c52w
- https://github.com/vyperlang/vyper/issues/3609
CVE-2023-42443 · published · modified · JSON