PyPI/pretalx CVE-2023-28458: unknown, EPSS 3.46%
pretalx 2.3.1 before 2.3.2 allows path traversal in HTML export (a non-default feature). Organizers can trigger the overwriting (with the standard pretalx 404 page content) of an arbitrary file.
Action: Upgrade pretalx to 2.3.2 or later.
pip install pretalx==2.3.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.3.1 | 2.3.2 | - |
Fixed versions
| 2.3.2 |
Sources
- osv: PYSEC-2023-40
- https://github.com/pretalx/pretalx/commit/60722c43cf975f319e94102e6bff320723776890
- https://www.sonarsource.com/blog/pretalx-vulnerabilities-how-to-get-accepted-at-every-conference/
- https://github.com/pretalx/pretalx/releases/tag/v2.3.2
- https://pretalx.com/p/news/security-release-232/
- https://github.com/advisories/GHSA-23fx-92m6-4f2g
CVE-2023-28458 · published · modified · JSON