PyPI/portage CVE-2016-20021: critical 9.8, EPSS 0.47%
In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the standalone emerge-webrsync downloads a .gpgsig file but does not perform signature verification. Unless emerge-we
Action: Upgrade portage to 3.0.47 or later.
pip install portage==3.0.47Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.0.47 | - |
Fixed versions
| 3.0.47 |
Sources
- osv: PYSEC-2024-10
- https://wiki.gentoo.org/wiki/Portage
- https://gitweb.gentoo.org/proj/portage.git/tree/NEWS
- https://bugs.gentoo.org/597800
- https://github.com/advisories/GHSA-pw5x-x5jw-ccmh
CVE-2016-20021 · published · modified · JSON