PyPI/openc3 CVE-2024-43795: medium 6.1, EPSS 0.48%
OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. The login functionality contains a reflected cross-site scripting (XSS) vulnerab
Action: Upgrade openc3 to 5.19.0 or later.
pip install openc3==5.19.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.19.0 | - |
Fixed versions
| 5.19.0 |
Sources
- osv: PYSEC-2024-100
- https://github.com/OpenC3/cosmos/security/advisories/GHSA-vfj8-5pj7-2f9g
- https://github.com/OpenC3/cosmos/commit/762d7e0e93bdc2f340b1e42acccedc78994a576e
CVE-2024-43795 · published · modified · JSON