PyPI/vyper CVE-2024-22419: critical 9.8, EPSS 0.77%
Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine. The `concat` built-in can write over the bounds of the memory buffer that was allocated for it and thus overwrite existing
Action: Upgrade vyper to 0.4.0b1 or later.
pip install vyper==0.4.0b1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0b1 | - |
Fixed versions
| 0.4.0b1 |
Sources
- osv: PYSEC-2024-103
- https://github.com/vyperlang/vyper/security/advisories/GHSA-2q8v-3gqq-4f8p
- https://github.com/vyperlang/vyper/issues/3737
- https://github.com/vyperlang/vyper/commit/55e18f6d128b2da8986adbbcccf1cd59a4b9ad6f
CVE-2024-22419 · published · modified · JSON