PyPI/exiv2 CVE-2024-25112: medium 5, EPSS 0.22%
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A denial-of-service was found in Exiv2 version v0.28.1: an unbounded recursio
Action: Upgrade exiv2 to 0.16.1 or later.
pip install exiv2==0.16.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.16.0 | 0.16.1 | - |
Fixed versions
| 0.16.1 |
Sources
- osv: PYSEC-2024-107
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-crmj-qh74-2r36
- https://github.com/Exiv2/exiv2/pull/2337
CVE-2024-25112 · published · modified · JSON