PyPI/langchain CVE-2024-2965: medium 4.7, EPSS 0.30%
A Denial-of-Service (DoS) vulnerability exists in the `SitemapLoader` class of the `langchain-ai/langchain` repository, affecting all versions. The `parse_sitemap` method, responsible for parsing site
Action: Upgrade langchain to 0.2.5 or later.
pip install langchain==0.2.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.2.5 | - |
Fixed versions
| 0.2.5 |
Sources
- osv: PYSEC-2024-118
- https://huntr.com/bounties/90b0776d-9fa6-4841-aac4-09fde5918cae
- https://github.com/langchain-ai/langchain/commit/73c42306745b0831aa6fe7fe4eeb70d2c2d87a82
- https://github.com/advisories/GHSA-3hjh-jh2h-vrg6
CVE-2024-2965 · published · modified · JSON