PyPI/vyper CVE-2024-24561: critical 9.8, EPSS 0.90%
Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In versions 0.3.10 and earlier, the bounds check for slices does not account for the ability for start + length to overflo
Action: Upgrade vyper to 0.4.0b1 or later.
pip install vyper==0.4.0b1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0b1 | - |
Fixed versions
| 0.4.0b1 |
Sources
- osv: PYSEC-2024-149
- https://github.com/vyperlang/vyper/security/advisories/GHSA-9x7f-gwxq-6f2c
- https://github.com/vyperlang/vyper/issues/3756
- https://github.com/vyperlang/vyper/blob/b01cd686aa567b32498fefd76bd96b0597c6f099/vyper/builtins/functions.py#L404-L457
CVE-2024-24561 · published · modified · JSON