PyPI/scrapy CVE-2024-1892: medium 6.5, EPSS 0.56%
A Regular Expression Denial of Service (ReDoS) vulnerability exists in the XMLFeedSpider class of the scrapy/scrapy project, specifically in the parsing of XML content. By crafting malicious XML conte
Action: Upgrade scrapy to 2.11.1 or later.
pip install scrapy==2.11.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.11.1 | - |
Fixed versions
| 2.11.1 |
Sources
- osv: PYSEC-2024-162
- https://huntr.com/bounties/271f94f2-1e05-4616-ac43-41752389e26b
- https://github.com/scrapy/scrapy/commit/479619b340f197a8f24c5db45bc068fb8755f2c5
- https://github.com/advisories/GHSA-cc65-xxvf-f7r9
CVE-2024-1892 · published · modified · JSON