PyPI/vyper CVE-2024-32648: medium 5.3, EPSS 0.41%
Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. Prior to version 0.3.0, default functions don't respect nonreentrancy keys and the lock isn't emitted. No vulnerable produ
Action: Upgrade vyper to 0.3.0 or later.
pip install vyper==0.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3.0 | - |
Fixed versions
| 0.3.0 |
Sources
- osv: PYSEC-2024-163
- https://github.com/vyperlang/vyper/security/advisories/GHSA-m2v9-w374-5hj9
- https://github.com/vyperlang/vyper/commit/93287e5ac184b53b395c907d40701f721daf8177
- https://github.com/vyperlang/vyper/issues/2455
- https://github.com/advisories/GHSA-m2v9-w374-5hj9
CVE-2024-32648 · published · modified · JSON