PyPI/zenml CVE-2024-2171: medium 4.8, EPSS 0.37%
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacke
Action: Upgrade zenml to 0.56.2 or later.
pip install zenml==0.56.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.56.2 | - |
Fixed versions
| 0.56.2 |
Sources
- osv: PYSEC-2024-170
- https://huntr.com/bounties/cee06a28-7e3b-460b-b504-69add838ebe8
- https://github.com/zenml-io/zenml/commit/68bcb3ba60cba9729c9713a49c39502d40fb945e
- https://github.com/advisories/GHSA-vwgf-7f9h-h499
CVE-2024-2171 · published · modified · JSON