PyPI/streampipes CVE-2024-31979: medium 4.3, EPSS 0.74%
Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements.
Action: Upgrade streampipes to 0.95.0 or later.
pip install streampipes==0.95.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.95.0 | - |
Fixed versions
| 0.95.0 |
Sources
- osv: PYSEC-2024-174
- https://lists.apache.org/thread/8lryp3bxnby9kmk13odkz2jbfdjfvf0y
- http://www.openwall.com/lists/oss-security/2024/07/16/11
- https://github.com/advisories/GHSA-9gr7-gh74-qg9x
CVE-2024-31979 · published · modified · JSON