PyPI/wordops CVE-2024-34528: unknown, EPSS 0.18%
WordOps through 3.20.0 has a wo/cli/plugins/stack_pref.py TOCTOU race condition because the conf_path os.open does not use a mode parameter during file creation.
Action: Upgrade wordops to 3.21.3 or later.
pip install wordops==3.21.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.21.3 | - |
Fixed versions
| 3.21.3 |
Sources
- osv: PYSEC-2024-175
- https://github.com/WordOps/WordOps/issues/611
- https://github.com/WordOps/WordOps/blob/ecf20192c7853925e2cb3f8c8378cd0d86ca0d62/wo/cli/plugins/stack_pref.py#L77
- https://github.com/advisories/GHSA-23qq-p4gq-gc2g
CVE-2024-34528 · published · modified · JSON